News‎ > ‎

Version 0.5.0 released

posted Mar 22, 2012, 2:20 PM by Alkis Georgopoulos   [ updated Mar 23, 2012, 3:37 PM ]
In version 0.5.0 the epoptes-client dependencies were changed, so you need to update your clients or LTSP chroots, otherwise you'll get a compatibility error message in the Epoptes UI. Changelog:
  • Fix typo in remote-assistance (LP: #961907).
  • Allow more than one epoptes instances to monitor/assist clients.
  • screenshot: don't crash if the connection breaks (LP: #954441).
  • epoptes-client: depend on python-gtk2, suggest ssvnc.
  • Move remote-assistance to epoptes-client to match dependencies.
  • Hide the remote assistance menu item when epoptes-client is not installed.
  • Fix windowed broadcast.
  • get-display: don't fail if DISPLAY has an invalid (cached) value.
  • Avoid disconnecting clients on broken DNS configurations (LP: #949055).
  • Fix "unlock" trunk regression (LP: 959522).
  • Remove the unused Constants class.
  • Allow pango markup in message sending.
  • Support ssvncviewer to cope with 24bpp displays (LP: #953512).
  • Increase certificate validity to 10 years (LP: #954076).
  • Point to epoptes(1), not (8), in README (LP: #953493).
  • Use a VNC password instead of allowing only localnet (LP: #937820).
  • Don't depend on zenity (LP: #955452).
  • Make `epoptes-client -c` contact localhost in fat chroots.
  • Allow epoptes-clients using XDMCP (LP: #950720).
  • Permit VNC'ing to the login screen (LP: #889669).
  • Fix "mute/unmute not found" error (LP: #953521).
  • Add Brazilian Portuguese, Hebrew, Slovenian, Ukrainian and Vietnamese translations. Many thanks to the translators!
Version 0.5.0 was released as 0.5.1 in Debian, while including some more translated strings, it will be published in Ubuntu as well in about a week.
Comments